Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MPLS/l2VPN Load Balance Issue (Equal Cost Paths) in IOS XR

Dears,

I am trying to do a load balance through 2 links in OSPF, but i am getting low traffic on one link and high traffic in other link and in other situations I am getting asymetric traffic, upstream through a vlan and downstream through the other vlan.

I have the following toplogy:

CE -- PE 1 (ASR9K) === PE 2 (ASR9K) --CE

Between PEs, I have configured 2 subinterfaces (Vlans) each one is going through different path through my network.

Configuration summary, l2vpn (bridge groups, PW), MPLS LDP, OSPF,

PE 1 Configuration:

mpls ldp

router-id 172.17.17.250

neighbor 172.16.16.17 targeted

label

  allocate for mpls

interface TenGigE0/0/0/3.1512

!

interface TenGigE0/0/0/3.1517

ipv4 access-list mpls

10 permit ipv4 172.17.17.0 0.0.0.255 any

router ospf ASR

router-id 172.17.17.18

redistribute connected route-policy permit-loopback1500-only

area 0

  interface Loopback1512 (172.17.17.18/32)

  interface TenGigE0/0/0/3.1512

   cost 5

  interface TenGigE0/0/0/3.1517

   cost 5

!

!

route-policy permit-loopback1500-only

  if destination in (172.17.17.250/32) then

    pass

  else

    drop

  endif

end-policy

bridge group ASR

  bridge-domain A

   interface Bundle-Ether1.1501

   !

   neighbor 172.17.17.20 pw-id 4100

    mpls static label local 4100 remote 4100

   !

  !

  bridge-domain B

   interface Bundle-Ether1.1504

   !

   neighbor 172.17.17.20 pw-id 4101

    mpls static label local 4101 remote 4101

   !

PE 2 Configuration:

mpls ldp

router-id 172.16.16.17

neighbor 172.16.16.18 targeted

label

  allocate for mpls

interface Bundle-Ether100.1517

!

interface GigabitEthernet0/0/0/1.1512

ipv4 access-list mpls

10 permit ipv4 172.16.16.0 0.0.0.255 any

20 permit ipv4 172.17.17.0 0.0.0.255 any

router ospf ASR

router-id 172.17.17.20

redistribute connected route-policy permit-loopback16

area 0

  interface Loopback1512 (172.17.17.20/32)

  interface Bundle-Ether100.1517

   cost 5

  !

  !

  interface GigabitEthernet0/0/0/1.1512

   cost 5

  !

bridge group ASR

  bridge-domain A

   interface TenGigE0/2/0/5.1501

   !

   neighbor 172.17.17.18 pw-id 4100

    mpls static label local 4100 remote 4100

   !

  !

  bridge-domain B

   interface TenGigE0/2/0/5.1504

   !

   neighbor 172.17.17.18 pw-id 4101

    mpls static label local 4101 remote 4101

   !

How can I do 50/50 load balance in that situation ? How the ECMP hash will work ?

Any advice would be appreciated.

Regards,

  • XR OS and Platforms
322
Views
0
Helpful
0
Replies