cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1491
Views
0
Helpful
2
Replies

trunk vrf

nwag_2009
Level 1
Level 1

Hi,

 

I am trying to establish a trunked (static, bgp)vrf link between two routers, how do you go about creating this. Do you need to use subinterfaces, Can you send some config examples please?

 

Thanks

2 Replies 2

Ruben Cocheno
Spotlight
Spotlight

You can have 2 types of setup:


For both scenarios you need setup the vrfs

 

ip vrf cust1

rd 1:1

 

ip vrf cust2

rd 1:2

 

1. Using a trunk

vlan 12

vlan 14

interface vlan 12
ip vrf forwarding cust1
ip address 172.16.12.1 255.255.255.0
!
interface vlan 14
ip vrf forwarding cust2
 ip address 172.16.14.1 255.255.255.0

 

2. Using SubInterfaces

 

interface FastEthernet0/0.12
 encapsulation dot1Q 12
ip vrf forwarding cust1
ip address 172.16.12.1 255.255.255.0
!
interface FastEthernet0/0.14
 encapsulation dot1Q 14
ip vrf forwarding cust2
 ip address 172.16.14.1 255.255.255.0

Tag me to follow up.
Please mark it as Helpful and/or Solution Accepted if that is the case. Thanks for making Engineering easy again.
Connect with me for more on Linkedin https://www.linkedin.com/in/rubencocheno/

One additional note; the "option 1" is for the 7600 or an IOS based device, for XR you would want to use the BVI method:

 

Define the "efp" (eg vlan trunk port)

int g 0/0/0/0.12 l2transport

encap dot1q 12

rewrite ingress tag pop 1 symmetric

 

Create a bridge group and link it to a BVI:

l2vpn

bridge group BLA

bridge-domain BLABLA

int g 0/0/0/0.12

routed interface BVI 10

 

int bvi 10

vrf cust1

ipv4 add 1.1.1.1 255.255.255.0

 

regards

xander