Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

VRF manipulation in IOS XR 4.2.1

Hello,

I can't find feature list of IOS XR 4.2.1 for ASR9K and can't find it in release notes of IOS XR 4.2.1.

Does IOS XR 4.2.1 support VRF Selection Using Source IP Address or VRF Selection Using ABF?

If it is not possible, what is the solution instead?

Thank you.

Everyone's tags (1)
7 REPLIES
Cisco Employee

VRF manipulation in IOS XR 4.2.1

here you can find release notes for 4.2.1

http://www.cisco.com/en/US/docs/routers/asr9000/software/asr9k_r4.2/general/release/notes/reln_a9k_421.html

VRF aware ABF is supported on ASR9k since 4.2.0.

Regards,

/A

New Member

VRF manipulation in IOS XR 4.2.1

I found it earlier, but I don't understand how to configure IOS-XR router

like this on IOS router:

access-list 40 permit source 10.1.0.0 0.0.255.255

access-list 50 permit source 10.2.0.0 0.0.255.255

access-list 60 permit source 10.3.0.0 0.0.255.255
!

route-map PBR-VRF-Selection permit 10

 match ip address 40

 set vrf VRF1

 !

route-map PBR-VRF-Selection permit 20

 match ip address 50

 set vrf VRF2

 !

route-map PBR-VRF-Selection permit 30

 match ip address 60

 set vrf VRF3

 !

interface Ethernet 0/1

 ip address 192.168.1.6 255.255.255.252 
 ip vrf forwarding VRF4 

 ip policy route-map PBR-VRF-Selection

 ip vrf receive VRF1

 ip vrf receive VRF2

 ip vrf receive VRF3 
Cisco Employee

Re: VRF manipulation in IOS XR 4.2.1

Here is a configuration example:

!     

ipv4 access-list ipv4-abf

10 permit ipv4 any any nexthop1 vrf 1 ipv4 10.10.1.2 nexthop2 vrf 2 ipv4 20.20.1.2 nexthop3 ipv4 30.30.1.2

!

ipv6 access-list ipv6-abf

10 permit ipv6 any any nexthop1 vrf 1 ipv6 2100::2 nexthop2 vrf 2 ipv6 2200::2 nexthop3 ipv6 2300::2

!

interface TenGigE0/1/0/12

ipv4 address 25.25.25.1 255.255.255.0

ipv6 address 2040::1/64

ipv4 access-group ipv4-abf ingress

ipv6 access-group ipv6-abf ingress

!

Regards,

/A

New Member

VRF manipulation in IOS XR 4.2.1

Cisco Employee

Re: VRF manipulation in IOS XR 4.2.1

There is no PBR on XR. You'd need to use ABF for NH manipulation which is in another VRF.

!

interface TenGigE0/1/0/12

ipv4 address 25.25.25.1 255.255.255.0

vrf VRF777

ipv4 access-group ipv4-abf ingress

!

!

ipv4 access-list ipv4-abf

40 permit ipv4 10.1.0.0 0.0.255.255 any nexthop1 vrf VRF1

50 permit ipv4 10.2.0.0 0.0.255.255 any nexthop1 vrf VRF2

60 permit ipv4 10.3.0.0 0.0.255.255 any nexthop1 vrf VRF3

!

Regards,

/A

VRF manipulation in IOS XR 4.2.1

Hi,

I am testing ABF on XR running on an old 12K in our lab, before upgrading few CRS in production.

Unforunately, cant seem to see ABF with NH as an option. I am running 4.2.3 in test.

Has thsi feature been scrapped off again ?

RP/0/3/CPU0:LAB-PE2(config-ipv4-acl)#permit ipv4 any any ?

  dscp           Match packets with given DSCP value

  fragments      Check non-initial fragments

  log            Log matches against this entry

  log-input      Log matches against this entry, including input interface

  packet-length  Check packet length

  precedence     Match packets with given precedence

            

RP/0/3/CPU0:LAB-PE2(config-ipv4-acl)#permit ipv4 any any

TIA

/Samir

Cisco Employee

VRF manipulation in IOS XR 4.2.1

Hi Samir,

AFAIK, ABF isn't supported on XR12K but only on ASR9000 and CRS platforms.

Kind regards,

N.

3565
Views
15
Helpful
7
Replies