cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
15493
Views
11
Helpful
2
Replies

Cisco devices - Default interface delay values

Hi!

I've been trying to find an overall scheme for understanding what the default interface delay would be across an Ethernet switching network. Essentially I am trying to fix a network's routing so that redundancy between sites is achieved via EIGRP metrics rather then via manual administrative distance adjustments across all infrastructure. There is a long story here... but one that is not really important towards the point of this post.

Basically, when looking online I can't really see a definitive guide saying "Ethernet is 1000usec default delay". The best I could find is a support forum post (https://learningnetwork.cisco.com/thread/6116). My point is that when looking at Nexus switches and some (not all) interfaces on a Cisco Catalyst 3750 the default interface delay is 10usec rather then the 1000usec suggested elsewhere. As some examples I have the "show run" segment for some interface and the "show interface" section of the same interfaces:

interface GigabitEthernet2/0/5

switchport access vlan 700

switchport mode access

spanning-tree portfast

ip dhcp snooping trust

!

interface Vlan700

description Data-Server-01

ip address 10.150.1.1 255.255.255.0 secondary

ip address 10.200.0.1 255.255.255.0 secondary

ip address 10.150.1.252 255.255.255.0

ip helper-address 10.1.0.27

no ip redirects

no ip unreachables

ip pim sparse-mode

!


3750-CORE#show int gig 2/0/5

GigabitEthernet2/0/5 is down, line protocol is down (notconnect)

  Hardware is Gigabit Ethernet, address is 0026.0ab5.6d85 (bia 0026.0ab5.6d85)

  MTU 9000 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, media type is 10/100/1000BaseTX

[...]




interface GigabitEthernet4/0/24

no switchport

ip address 10.200.50.254 255.255.255.252

ip summary-address eigrp 1 10.0.0.0 255.0.0.0


3750-CORE#show int gig 4/0/24

GigabitEthernet4/0/24 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 0026.0a95.f141 (bia 0026.0a95.f141)

  Internet address is 10.200.50.254/30

  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

[...]




interface GigabitEthernet5/0/24

description Telstra Secondary WAN Link

no switchport

ip address 10.200.50.250 255.255.255.252

ip summary-address eigrp 1 10.0.0.0 255.0.0.0


3750-CORE#show int gig 5/0/24

GigabitEthernet5/0/24 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 0026.0a95.f159 (bia 0026.0a95.f159)

  Internet address is 10.200.50.250/30

  MTU 9000 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

[...]

So all of the above are from the same 3750G switch stack. The only pattern I can see in the above is that the 10usec NICs are "routed interfaces" and the 1000usec NICs are "switchports". In GNS I have a 3700 router setup and all NICs are 1000usec, granted it is a different platform (a router rather then a switch).

Anyone know what the pattern here is? Is there any reference documents that explain this clearly?

The reason I want to know is that EIGRP is in use for dynamic routing failover. I need to calculate delay across several links to provide a deterministic and non-load balanced routing topology (i.e. active/standby). I'm aware there are likely easier ways to achieve my routing requirements (OSPF comes to mind) but I'm stuck with a single AS EIGRP topology for the moment. Summarily, I just want to know about interface delay default settings.

Thanks!

1 Accepted Solution

Accepted Solutions

Hello Jonathan,

Great, thanks for all that information..

Really appreciated it

Please mark the question as answered so future users having the same questions can use it.

Kudos for you

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC

View solution in original post

2 Replies 2

I figured it out by myself. It is an interface speed thing. The interfaces are 10/100/1000 capable. Depending on the negotiated bandwidth the default delay changes. Switchport/routed port has no effect. If you leave them "auto negotiated" then essentially the delay negotiates to match the port speed as per the below:

1Gbps = 10usec

100Mbps = 100usec

10Mbps = 1000used

I don't know what 10Gbps looks like but I imagine it is 10usec still. Below is some evidence from GNS:

R1#show int fast 0/0 | inc DLY

  MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,

R1#show run int fast 0/0

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

end

R1#conf t

R1(config)#int fast 0/0

R1(config-if)#speed 100

R1(config-if)#^Z

R1#show int fast 0/0 | inc DLY

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

It is important to note that changing the "bandwidth" statement doesn't change the negotiated "delay". Only the "speed" will change delay... but please note that changing "speed" command is potentially network impacting. The "speed" command changes the literal interface capabilities for negotiating link speed, whereas changing "bandwidth" and "delay" changes an imaginary representation of link throughput capabilities.

Anyways, there you go... hope someone finds this handy.

Hello Jonathan,

Great, thanks for all that information..

Really appreciated it

Please mark the question as answered so future users having the same questions can use it.

Kudos for you

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card