cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1300
Views
0
Helpful
9
Replies

Multicast Design - between sites

Bilal Nawaz
VIP Alumni
VIP Alumni

Hello,

I have 4 sites, 2 of them will be producing multicast streams (at the moment), but currently at one of the sites is the RP. This may cause us problems because of unecessary traversal of the links for this kind of traffic. Each site has a pair of ASR 1K's that are doing the WAN aggregation - all point-to-point circuits. One of them will be the RP.

How do I go about splitting this up so I have one RP that looks after a certain multicast address group for one site, and another RP that is taking care of another group?

I also read about multicast domains, I was thinking, would it be better if I split the 4 in to their separate multicast domains, have one RP per site and have some sort of peerings between all sites, in the case that someone is interested in the multicast traffic from other sites?

Any sort of idea's suggestions and config examples would be much appreciated.

tia

Please rate useful posts and remember to mark any solved questions as answered. Thank you.       

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
9 Replies 9

Gabriel Hill
Level 1
Level 1

//How do I go about splitting this up so I have one RP that looks after a certain multicast address group for one site, and another RP that is taking care of another group?//

ip multicast-routing

ip pim RP-address 1.1.1.1 2

ip pim RP-address 2.2.2.2 3

access-list 2 permit 224.1.1.1

access-list 2 permit 224.1.1.2

access-list 2 permit 224.1.1.3

access-list 3 permit 224.2.2.2

access-list 3 permit 224.2.2.3

access-list 3 permit 224.2.2.4

(http://www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a0080094821.shtml#autowithone)

I have always been fuzzy on the meaning of multicast domains. I always thought that having separate "multicast domains" meant you could re-use the same multicast address, and it wouldn't conflict with your other sites.

Hi Bilal,

I think I'd use an IP Anycast RP approach having an Anycast RP in each site and the other multicast routers in your environment configured with a static RP of the Anycast RP address. To finish things off, you peer the two Anycast RPs using Multicast Source Discovery Protocol (MSDP).

This solution would give you load sharing of the registrations across the two RPs (assuming sources in both sites), the RP is in the same site as the sources/receivers and you get rapid convergence i.e., the speed of your IGP, in the event of a failure of one of the devices acting as the RP.

There's a more detailed explanation and configuration example in the Anycast RP white paper.

Regards

Hey Steve/Gabriel,

Thank you for this information, been great helping me understand a bit more about multicast. Have a final question... Am i able to use a combination of both? I do think the anycast RP solution with msdp per site is an elegant way of setting things up.

Example: lets say I have site A and site B

Site A & B both have:

ASR1001-01 and 02 will have an MSDP peering between each other, sharing the same RP address

Also filtered by acls to specify for which address group the RP should be for?

They all will know about the different multicast sources right?

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Hello Bilai
To define specific source m/c see link below

http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti_igmp/configuration/xe-3s/imc_ssm_map.html

Res
Paul

Sent from Cisco Technical Support iPad App


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello Bilal,

you can achieve to use MSDP with source active messages filtering over the MSDP sessions

a) filtering inbound

see

http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti/command/imc_i2.html#wp5749501050

ip msdp [ vrf vrf-name ] filter-sa-request { peer-address | peer-name } [ list access-list ]

>> By default, the router honors all SA request  messages from peers. If this command is not configured, all SA request  messages are honored. If this command is configured but no access list  is specified, all SA request messages are ignored.  

in this way you filter inbound on received SA messages from MSDP peer

b) filtering outbound

Alternatively you can filter out to the neighbor using

http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti/command/imc_i2.html#wp3266518951

ip msdp [ vrf vrf-name ] sa-filter out { peer-address | peer-name } [ list access-list-name ] [ route-map map-name ] [ rp-list { access-list-range | access-list-name } ] [ rp-route-map route-map reference ]

c) ip msdp redistribute

There is a third option that is ip msdp redistribute

ip msdp [ vrf vrf-name ] redistribute [ list access-list-name ] [ asn as-access-list-number ] [ route-map map-name ]

http://www.cisco.com/en/US/docs/ios-xml/ios/ipmulti/command/imc_i2.html#wp2930691609

Hope to help

Giuseppe

Hello Giuseppe, I dont quite understand MSDP in this context - I am very new to multicast. Does this mean I have MSDP peerings with each and every single one of my WAN routers (ASRs). What will the filters be helping me achieve?

In my case I can afford to use different multicast addresses at each site...

I had a go with a multicast lab with a basic setup:

All routers have converged through OSPF, each link is a point-to-point link.

I have created MSDP peering with ETASR01 and 02 sharing the 20.1.1.1 RP address (anycast)

And have allowed that RP address to be the RP for the multicast group 224.1.1.1

Also the same with SQPASR01 and 02, with 10.1.1.1 RP address only allowed for 234.1.1.1

Just an example config I have done:

hostname ETASR01

!

ip multicast-routing

!

interface Loopback0

ip address 20.1.1.1 255.255.255.255

ip ospf network point-to-point

ip ospf 1 area 0

!

interface Loopback1

ip address 20.0.0.1 255.255.255.255

ip ospf network point-to-point

ip ospf 1 area 0

!

interface FastEthernet0/0

ip address 192.168.20.1 255.255.255.252

ip pim sparse-mode

ip ospf network point-to-point

ip ospf 1 area 0

!

interface FastEthernet0/1

ip address 192.168.21.1 255.255.255.252

ip pim sparse-mode

ip ospf network point-to-point

ip ospf 1 area 0

!

interface FastEthernet1/0

no switchport

ip address 192.168.1.2 255.255.255.252

ip pim sparse-mode

ip ospf network point-to-point

ip ospf 1 area 0

!

router ospf 1

log-adjacency-changes

!

ip pim rp-address 10.1.1.1 IPTV

ip pim rp-address 20.1.1.1 Altiris

ip msdp peer 20.0.0.2 connect-source Loopback1

ip msdp originator-id Loopback1

!

ip access-list standard Altiris

permit 224.1.1.1

ip access-list standard IPTV

permit 234.1.1.1

!

This provides me with my anycast - redundancy

And also provides me with control on which RP is taking care of multicast groups. Does this look right?

I tested with an 'ip igmp join-group 234.1.1.1' on IPTV and did a ping from Altiris to the address of 234.1.1.1 and I did get a response back from the interface which shows that it is working.

Thank you for your help.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

can I use the same multicast group addresses for the IPTV channels in the two sites ?

Joseph W. Doherty
Hall of Fame
Hall of Fame
As an aside, unless you config RP to continue to be used, by default, the multicast streams should switch to shortest path for each source to destination.

So if i will make msdp betwern two sites and also anycast (the same rp betwern two sites) can i use the same multicast group addresses for the channels and the reciever in each site will reach to the source (channel multicast group address) which closed to the rp( shortest path) correct?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: