×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Password recovery Nexus 5000

Video

Mon, 05/19/2014 - 12:18
Oct 9th, 2010
User Badges:
  • Red, 2250 points or more
Video Upload: 

This video will show you how to perform the password recovery on Nexus 5000 running later than 4.0(0)N1(2a) code.


The command used during this process is CTRL + ]


Note that you can only change the password for the user admin with a password recovery

Loading.
jpabellon Mon, 10/25/2010 - 08:35
User Badges:

What if you've configured AAA, how does this affect the password recovery procedure.

Lucien Avramov Mon, 10/25/2010 - 09:51
User Badges:
  • Red, 2250 points or more

The first steps are same as on the video.


There is an additional step if you have AAA:

Until you are running a code that has the fix for CSCsw49543, you need to unplug physically the cables connecting the Nexus 5000 to your AAA server, so there is a fallback that can happen and use the local authentication. Once you run a code with this fix, it changes the console auth login to be only local after the password recovery is done, so you won't have to unplug your cables going to the AAA server anymore.

Peter Kim Tue, 11/02/2010 - 07:22
User Badges:

Lucien,


I've been trying to reset the 5K.  It just doesn't work.  I found exact same document for password recovery.  It doesn't work.  After I reset the admin-password with my own password, it still doesn't reset to what I changed to.  I watched your video and it is exactly same thing.  Am I missing something here?

Lucien Avramov Tue, 11/02/2010 - 11:40
User Badges:
  • Red, 2250 points or more

Peter, you probably have AAA configured, have you tried to unplug all the connections on the 5k, besides your console, so fallback can happen?


Else, there is a method that will make you loose all your configuration:


1. Clear nvram and delete the startup config and init the bootflash:



  switch(boot)# clear nvram

  switch(boot)# init system


2. Reboot and be ready to load kickstart from tftp:


loader> set ip<ip_address>  <mask>

loader>set gw<gw_address>


That should set your mgmt0 network up.


Then you can boot from your tftp server:


loader>boot tftp://1.2.3.4/kickstart_image_name_on_tftp_server


That will get you to the switch(boot)#


From there you can complete your password recovery procedure and load the system image

Peter Kim Tue, 11/02/2010 - 12:20
User Badges:

Thanks for your quick reply.  Actually, I already did "write erase" instead of "clear nvram".  After reloading with IOS image, it came back with a prompt to reset admin password.  Once I reset the password, I was done.  I was able to run "copy runnning start" command.  I didn't have to use kickstart image.

princekennedy Mon, 05/19/2014 - 12:19
User Badges:

Thanks Lucien I just got a datacenter job and your videos helps me a lot in deploying vpc's and fex's thanks very much for your good work.

0 votes

Actions

This Video

Related Content

 

 

Trending Topics: Other DC Subjects