×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

How to restore a Cisco Nexus Switch from loader prompt

Video

Thu, 06/22/2017 - 13:06
Aug 8th, 2011
User Badges:
  • Red, 2250 points or more
Video Upload: 

This videos shows how to restore a Cisco Nexus 5000/2000 series or Cisco Nexus 3000 series switch from the loader> prompt.


Summary steps:

-load kickstart from TFTP server, when not present on bootflash:

-copy kickstart and system images from a TFTP/FTP server

-load system image

-finish the install with install all

Loading.
Asma.Daghar Wed, 06/04/2014 - 21:58
User Badges:

Hi, 

 

I am facing a problem, I am using the tftpd64 TFTP server and trying to load my image to the N6K. It loads the image, Put right in the end it gives me this comment : TFTP ERROR 0 ( CODE ERROR) 

So I am stuck in that, tried to change setting so many times, and I noticed in the TFTP server log views that there is a block Ack#d....

Any idea what to do?

Your help will be appreciated

Thanks, 

A

jwood2012 Wed, 10/07/2015 - 07:26
User Badges:

Hello, 

        I'm getting the same error trying to tftp the image to a 5548. It loads the image, but in the end it gives error: TFTP ERROR 0 ( CODE ERROR).

Were you able to solve this issue? 

cristian26 Tue, 12/15/2015 - 07:06
User Badges:

its been a long time since you posted, but maybe if you try by FTP ( bin mode). Its faster and easier.

Must be in ftp bin mode, otherwise the image might get corrupted.


jwood2012 Tue, 12/15/2015 - 07:16
User Badges:

Hi, 

I was getting the TFTP ERROR 0 ( CODE ERROR) when connecting the switch locally to my PC and using TFTP64. I ultimately ended up connecting the nexus 5548 to our production network and tftp'ing the image from our solarwinds server running on window 2008 and was able to successfully load the image onto the switch. I couldn't speak to why it worked from the solarwinds server and not my windows PC, perhaps something w/the security settings on my PC. Hope this helps. 

suketu.patel1 Thu, 01/08/2015 - 12:20
User Badges:

I connected to mgmt0 port, changed IP & GW at loader.  But still can't get file to upload.  Im not able to ping my Mac to mgmt0 IP.  Is there something I'm missing?

 

thanks

 

Hani Elgaali Wed, 02/04/2015 - 15:20
User Badges:

I am also having the same issue with N5K, not able to ping the mgmt0 from my laptop where the tftp srv.

What is the problem? did you find any solution?

Thanks,

Hani 

ppalmerjr Fri, 11/20/2015 - 13:58
User Badges:

Did you ever figure out what this issue was?  I'm at the loader prompt and was able to set the IP,GW and mask but am unable to ping mgmt0 as well.  

prasadchwdry Wed, 03/16/2016 - 06:52
User Badges:

Did you able to resolve you issue??? I do have the same problem. It got stuck in booting mode and not moving forward. Any suggestions please.

ondrejbardon Fri, 12/18/2015 - 00:53
User Badges:

Hi,

mgmt0 when in loader prompt is not reachable by ICMP. Until you use tftp command you will not even see MAC address behind port where mgmt0 is connected. It's normal situation

Ondrej

ondrejbardon Fri, 12/18/2015 - 00:57
User Badges:

I faced issue on my N5k when I got into boot prompt.

The mgmt0 IP address was unchanged and same as I set in loader prompt but tftp and telnet still showed "Network is unreachable".

To resolve this I jumped to configuration mode and configured IP address and default gateway one more time using exact the same values as before.

Hope this helps someone.

nikmat.jayadi Mon, 02/15/2016 - 22:22
User Badges:

hi lucient,

i am facing the same problem. the nexus 7000 boot from loader>

i have follow this step but find error like this :

loader> boot tftp://172.16.1.1/n7000-s2-kickstart.6.2.14.bin                   
Found i82576 [3:0.0] at 0x2020, ROM address 0x7d80
Probing...[i82576]
Management port
Ethernet addr: E4:C7:22:16:D1:A8
Link UP in 1000/full mode
Address: 172.16.1.2
Netmask: 255.255.255.0
Server: 0.0.0.0
Gateway: 172.16.1.1
Address: 172.16.1.2
Netmask: 255.255.255.0
Server: 0.0.0.0
Gateway: 172.16.1.1
Address: 172.16.1.2
Netmask: 255.255.255.0
Server: 172.16.1.1
Gateway: 172.16.1.1
 Filesystem type is tftp, using whole disk
Booting: /n7000-s2-kickstart.6.2.14.bin console=ttyS0,9600n8nn quiet loader_ver
="4.1.9"....
...............................................................................
..............................Retry 1: Congestion or cable issue
Retry 1: Congestion or cable issue
Retry 1: Congestion or cable issue
Retry 1: Congestion or cable issue
Retry 1: Congestion or cable issue

need your advice thanks

prasadchwdry Wed, 03/16/2016 - 06:56
User Badges:

Hi Lucien,


I trying to recover the image from TFTP server, when i ran the boot from TFTP server it got stuck in booting prompt. I waited like half hour but no luck. Any suggestions please.


How do i know is it really booting or it got stuck here???


loader> boot tftp://10.1.220.254/TFTP/n5000-uk9-kickstart.5.2.1.N1.8b.bin
Address: 10.1.220.253
Netmask: 255.255.255.0
Server: 10.1.220.254
Gateway: 10.1.220.254
Booting: /TFTP/n5000-uk9-kickstart.5.2.1.N1.8b.bin console=ttyS0,9600n8nn quiet
 loader_ver="pr-1.3"....


Seth Hendrix Wed, 06/14/2017 - 12:57
User Badges:

I'm having this same issue. I just put the laptop in the rack and hope it resolves itself overnight.

Did you ever come to a conclusion on this?

shendrix1985 Thu, 06/22/2017 - 13:06
User Badges:

I'm having a different issue now, but this problem was caused by having the port my laptop and mgmt port set to "switchport mode trunk" instead of "switchport access vlan ##".

naveenvictory64... Fri, 07/15/2016 - 07:27
User Badges:

hi my nexus got stuck in loader promt ..i dont have the image s tried to download it from cisco website asking for contract details which i dont have ..i gave sn no looks like warrenty is expired 


please can some body provide the images it will be helpfull for me 


Thanks 

0 votes

Actions

This Video

Related Content

 

 

Trending Topics: Other DC Subjects