License validation

Unanswered Question
Jun 23rd, 2006
User Badges:

I have installed LMS on the remote site, using the evaluation license. After the installation was complete, I've got my license file from cisco.com. After using this license I've received a message " You have added an upgrade license. But the Proof of Purchase is not validated for upgrade license. Please run the utility validateupgrade from C:\PROGRA~1\CSCOpx\bin to validate the upgrade. ". The Status column of license information page said "Purhased" and the Expiration Date was "Never". It seems to be clear, but i have two questions.

1. Validateupgrade requires the installation CD in the CDROM. But installation took place on a hardly accessible remote site. Is there any other way to validate the license?

2. I've never met the requirement to validate the license before. Why could it appear for this installation?


Thank you.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (3 ratings)
Loading.
miheg Fri, 06/23/2006 - 12:15
User Badges:
  • Gold, 750 points or more

Not sure why you have never seen this. I see it every time.


If you copy the contents of the CD in a directory on the machine you can use the subst command to make that directory appear as a drive.


e.g. subst g: c:\temp\dfm_1.2


That way you can validate using g: as the drive


Cheers,


Michel

p_kiselev Mon, 06/26/2006 - 03:40
User Badges:

Thank you for the advice. Sadly it does't work neither for validateupgrade nor for dfmvalidateupgrade. In both cases i choose validation by the cd, enter path to the disk made by subst command (disk contains full copy of CD), but in response i get "Upgrade validation failed", without any detail.Maybe I've missed any details?


miheg Mon, 06/26/2006 - 04:01
User Badges:
  • Gold, 750 points or more

You are probably hitting a bug where the upgrade always fails.


bugid CSCsa70833


You require a patch from the TAC.


Cheers,


Michel

p_kiselev Mon, 06/26/2006 - 06:45
User Badges:

No, I'm afraid not. The bug description states that the bug is fixed with the December 2005 Updates package. I have it installed. Also this bug affects the DFM 1.2 CD-ROM validation and I've got a newer version.

Martin Ermel Tue, 06/27/2006 - 00:43
User Badges:
  • Blue, 1500 points or more

try this:

- Copy the license file to a directory on the LAN Management Solution (LMS) server.

Note: The LMS**.lic should be in some other directory other than $NMSROOT/etc/licenses and must have read permission for casuser.


try deleting the current license files. Perform this procedure:

- Open the Command Line Interface (CLI) and issue the # pdterm LicenseServer command

- Go to CSCOpx\etc\licenses and delete all *.lic files.

Note: LMS***.lic file should not be copied to this directory directly. If it is there, move it to some other directory.

- Issue the pdexec LicenseServer command.

- Update the LMS**.lic file from the User Interface (UI). Go to Server > Admin > Licensing.

- If you have an upgrade license, validate the upgrade, as shown:

For Solaris:

csh

setenv LD_LIBRARY_PATH /opt/CSCOpx/lib:/opt/CSCOpx/objects/db/lib

/opt/CSCOpx/bin/validateupgrade


For Windows

cd ..\CSCOpx\bin\

.\validateupgrade


- Close all the browser sessions. Open a new browser, launch the CiscoWorks, and check for the popup message.


HTH

p_kiselev Tue, 06/27/2006 - 01:52
User Badges:

Thanks a lot for the answer. I've found that it was partially my fault because I used images of new CDs for validation instead of the old ones.

Actions

This Discussion