Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

License Key from Cisco is NOT Working.

Hello All,

Device: Cisco Wireless Controller 2504 (AIR-CT2504-K9)

We had purchased an Access Point Upgrade License for our Wireless Controller and when I try to upload the key to the WLC, I get a message that there were no valid Licenses found. We purchased the License from our 3rd party Cisco provider and our Rep had sent me 2 PAK numbers the other day for the Licenses. So I went on Cisco's site and entered the PAK Numbers (*there were 2 PAK Numbers) and after I entered both of those the SKUs that came up were: L-LIC-CT2504-UPG and L-LIC-CT2504-1A.

So I chose to download the License files and when I did I received a ZIP file containing one html file with instructions and one .lic file containing the License.

Here is what I see when I try:
        (Cisco Controller) > license install tftp://192.168.x.xxx/Cisco_WLC2504_Licenses/license_file_name.lic
        Transfering licenses from tftp://192.168.x.xxx/Cisco_WLC2504_Licenses/license_file_name.lic
        License installation: No valid license found to be installed

Anyone know why I would be receiving this error? I tried uploading to the WLC from both the Web Interface and the CLI with the same result.
I also tried having them email me the .lic file instead but I get the same thing when I try to upload it. 

Any ideas?

Thanks,
Matt

2 REPLIES
Cisco Employee

This can be an issue due to

This can be an issue due to UDI mismatch. The Unique Device Identifier (UDI) standard uniquely identifies products across all Cisco hardware product families, enabling customers to identify and track Cisco products throughout their business and network operations and to automate their asset management systems. 

The UDI is burned into the EEPROM of controllers. All licenses are tied electronically to UDI of each controller. 

If you open a TAC case with licensing team, they can help you regenerate the license as per your controller UDI, it should work than.

 

-Thanks

Vinod

**Encourage Contributors. RATE them**

-Thanks Vinod **Rating Encourages contributors, and its really free. **
New Member

Hey Vinod, thanks for the

Hey Vinod, thanks for the reply!

We had received an Access Point from our Cisco VAR partner and also ordered the License so we could add a 6th AP to the WLC. When we received the AP in the Mail the License was not with it so we emailed our acct rep and asked him for it, which is when they had me run the "show udi" command in order to give them the Serial Number so they could get me the PAK number. Which is I assume what you were talking about with the UDI (Unique Device Identifier)?

The License file itself contains the correct serial number, which is why I'm confused as to why it's not working. We don't have a SmartNet for this device so one of our Techs through our Cisco Var partner is contacting their Cisco Account Rep to find out what's going on. I guess I'll just wait till I hear back from them, and we'll see what they say. I even tried doing the Get Existing option on Cisco.com for the Product License Registration section of the site, which also did not work.

The strange thing is, when I did the Get Existing option and I downloaded the License file again, the Filename was different then it was the first time around... Not sure if this is normal or not, but I just thought that was strange.

Thanks Again for the reply Vinod..!

Thanks,
Matt

106
Views
4
Helpful
2
Replies
CreatePlease to create content